What version of X-Particles do I need to follow along?

X-Particles 3.5 or higher is recommended.

Still need help? Contact Us Contact Us