Blender Importer

Compatibility

Blender versions 3.4.x up to 4.0.x recommended for best experience. (Windows and macOS)


NOTE:

  • Any scenes that were created in Blender 3 using our content will work in Blender 4.
  • The material library is compatible with Cycles/Eevee
  • The importer may also work on Linux, however this has not been tested and is not officially supported.

This is a Step by Step Install Guide, you can also check the video guide from this link.


Installation

Download the GreyscalegorillaBlenderImporter.zip file for Blender from this link. You don't need to unzip the file since Blender allows you to select the zip itself to add the plugin.


Start Blender. Go to the “Edit” menu and click “Preferences”

Select Add-ons from the left side of the dialog, then click the Install button on the top right and browse for the downloaded zip file.

In the dialog that appears, select the downloaded GreyscalegorillaBlenderImporter.zip file and press "Install Add-on".

Note: If you have unzipped the zip file, then you can just select the greyscalegorilla_blender_importer.py file instead.


Enable the add-on by checking the checkbox next to "Import-Export: Greyscalegorilla Material Importer".

If you can't see the plugin listed then type "greyscalegorilla" in the search box on the top right.


The Importer is now enabled and you can access it from "File->Import->Greyscalegorilla Material"

Usage

To use the importer click "File->Import->Greyscalegorilla Material" from the menus.

This will open a file picker.

In the dialog that appears you can select a folder containing the unzipped contents of the material file that was downloaded from the Catalog.

Note that each material has been unzipped into its own individual folder based on the zip file name. You can choose to select an individual folder or you can select a parent folder, as shown below.

Warning: Do NOT select a root folder, such as your C drive, as it will search through all subfolders for the materials, which may take some time.

You will then be presented with a list of materials found in the folder and all of its subfolders.

Check one, or more, of the materials and then press the OK button to import.


A dialog will then appear to tell you that it has successfully imported the materials. Click OK again.

Go to the Blender material panel and select the imported materials to assign to any object in your scene.


Removing the Importer

Open the preferences dialog from "Edit->Preferences"

Select Add-ons on the left hand side

In the search box on the top right, type in "greyscalegorilla"

Expand the Add-on information and press the Remove button.


Updating the Importer


When a new update for the Importer is released you will first need to remove the existing one by following the above steps "Removing the Importer".

After removing the previous version you can now follow the Installation steps again to install the new one.

After installing you can use the new importer immediately, no need to restart Blender.


For additional instructions about Add-ons see the official blender add-on documentation.

Still need help? Contact Us Contact Us